Deinterlacing Video Files

Caspar Channel Config is 1080i5000 and the consumer is Decklink Extreme 4K.

Quicktime RLE footage is stuttering

Mediainfo:

Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Color space                              : RGBA
Bit depth                                : 8 bits
Scan type                                : Interlaced
Scan type, store method                  : Interleaved fields
Scan order                               : Top Field First

I tried to deinterlace footage with this casparcg config-change:

<ffmpeg>
    <producer>
        <auto-deinterlace>all</auto-deinterlace>
        <threads>4</threads>
    </producer>
</ffmpeg>

Now the output is much better and stutters only sometimes (when the animation of lower thirds slows down)

I saw there is another option to deinterlace footage:

PLAY 1-1 MOVIE FILTER yadif=1

What’s the difference weather using the config-change or the command-filter?

There are two kinds of stutter you may encounter. The first is from a wrong interlace sequence (scan order), the second is from a performance problem.

As from your specs the first problem should not happen, as a 1080 i 50 channel should be top field first. Are the clips also 1080? If no, it could be an issue while scaling the video. If yes, you maybe see the second, a performance problem. Please key in “DIAG” into the Caspar console window and play such a clip. From the graphs plotted you should be able to see performance issues, like dropped frames etc.

The difference is, that using the setting you always deinterlace, when needed, while with the command you interlace the current clip (regardles if it need it or not).

Privacy Policy   Terms of Service