Decklink producer

i am trying to take sdi input from decklink card and want to out using different decklink port so will you please tell me that is it possible in 2.0.7 server. if yes then how can i do that. what are the required configuration for that.

Suppose you are using default configuration file of casparcg server.( which means no decklink consumer).

To take input from first card
Play 1-1 decklink 1

To tkae output from card 2, 3 and 4
add 1 decklink 2 embedded_audio
add 1 decklink 3 embedded_audio
add 1 decklink 4 embedded_audio

1 Like

i have run command play 1-1 decklink 1but nothing is happening.
in cmd there are error showing that could not enable video input. file not found no match found for parameters.

Use the config file which is shipped with casparcg server.

It depends on your configuration. What Decklink card(s) do you have, and what channel(s) are already used by Caspar. Understand that you only can use a channel as input as long as it is not already used.

Heres the more newbie answer:
I presume you have a multichannel (or multiple) Decklink-cards, Duo, Quad, Duo2 or Quad2
heres is a apart from my config file

 " <channels>


This tells the CasparCG server to output channel 1 to Decklink channel 1.
Then in the client drag from Tools/other “decklink input” to the rundown
On the far right in the output you put then right server, channel 1 and any layer
Under the Decklink output you configure the device to 1, format to that format that your putting in
I havent relly understud why you in the client choose device 1 as input device, put I think that the logic is that that is the first one that is no in use. Every Decklink-channel you configure in the config-file is in use when you start the server, so the ouput has to be one that you dont have in your config-file.
This is how I have understand it, but it can be that I have just simplefied it for me.
Hope this was to some help

can someone please guide complete parameters for Decklink Consumer
as Vimlesh suggest for embedded audio… add 1 decklink 1 embedded_audio
but how can we add decklink with latency, keyer and buffer depth parameters

add 1 decklink 1 embedded_audio keyer external etc ?

with command add 1 decklink 1 i’m getting error

[2019-04-08 17:26:08.065] [3420] [error] DeckLink HD Extreme [1-1|PAL] Failed to enable external keyer.
#202 ADD OK

I am trying to add a video input feed through my decklink card. I have somewhat of an understanding on how to set things up on the “consumer” side using the config file … but i am at a total loss on the “producer” side. I am using three separate outputs (1) screen (2) decklink and (3) NDI. Obviously, the video input is on the decklink card. From what I am reading on the forum, I would use AMCP protocol but I am at a loss on the commands or where that would be entered. I can clearly see the video input through decklink software, but don’t know how to get it to the software.

Thank you for your time.

If the input format is the same as the channel format, you can ignore it
Change the 2 with the id of your input.
It takes more than a second to bring that up so you might want to use LOADBG with a transition and then PLAY manually.

What rrebuffo gave you is the raw AMCP command. You could also use the official client. It has a command for that:

I am not using the official CasparCG client. Working with Redcast Ontime and trying to route video into the live input. Doubt I could route video through both but not sure.

Thanks but I am confused where i would enter that line. Not in casparcg.config, right? My input would be the same as output (1080i5994)

So, live video would not come up right away?

Usually this would require to enable internal keyer (the card passes through the video and overlays caspar’s output) but you say you’re using redcast ontime. If you play out recorded media, that media would always be showed over the live input (video and audio). Not an ideal situation.
Redcast has an option for live input. You need to put there the media path for that, in your case DECKLINK DEVICE n

sorry for asking but where would i put command DECKLINK DEVICE n?

open the settings window, in the video&logo tab there is a live input field:

replace the n with the number of your card input

Thank you. I am using Redcast Ontime version at the moment. I have seen this video before and the tab he mentions in the version of software he is using is no longer available in the version I have. I am looking around to see if it could be someplace else in the settings but haven’t found it.

Right click the playlist and select Insert Live. Once added, right click the LIVE EVENT item and select Media > Settings...
There you can write the command

Success!!! Thank you for your help!