Deckink Duo card no output

Hi,
i am new to the caspar. I have a decklink duo 2 card connected to a Blackmagic ATEM and somehow however i set up the config file i cannot get signal through SDI 3 and SDI 4.
I have read through a lot of topics and tried to set this up as 1 double connector plus 2 single or just 4 single, but i only get signal on SDI 1 and 2. When i start the server it does say failed to load external keyer. I tried server 2.3.3 and 2.2 as i am running on windows 11.
I tried to disable decklink 3 and 4 in the device manager and re-enable it, but it did not solve it.
I use the latest client as well. My latest config is this for 4 single connectors. I have SDI 3 and 4 working as i can put through signal with other programs. From the error log i can see that decklink 2 -2
get initialized than the decklink consumer gets uninitialized.

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <log-level>info</log-level>
  <paths>
    <media-path>C:\Users\accou\Desktop\Caspar Server\media</media-path>
    <log-path>C:\Users\accou\Desktop\Caspar Server</log-path>
    <data-path>data/</data-path>
    <font-path>font/</font-path>
    <template-path>template/</template-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
      <video-mode>1080i5994</video-mode>
      <consumers>
        <decklink>
          <device>1</device>
          <embedded-audio>false</embedded-audio>
          <latency>normal</latency>
          <keyer>external</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5994</video-mode>
      <consumers>
        <decklink>
          <device>2</device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>default</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5994</video-mode>
      <consumers>
        <decklink>
          <device>3</device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>default</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5994</video-mode>
      <consumers>
        <decklink>
          <device>4</device>
          <embedded-audio>false</embedded-audio>
          <latency>normal</latency>
          <keyer>external</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
  </channels>

Anybody has any ideas?

You can not have 4 channels defined in the config, when you have keyers set to external, as this needs 2 outputs. You also need to set the outputs in the Control Panel Applet the way you want it.

You can set it so, that there are two BNC assigned to one channel. Use this for an extenal key (Key and Fill). Set channels to a single BNC to have a simple output or input. After that setup the config accordingly.

Thank you for the tip. I changed the device numbers and i actually found out that that one of the ATEM inputs is faulty so no video was showing. It works now all fine. Thank you!

Try deleting <keyer>...</keyer> in config file in every decklink consumer and use only <keyer>internal</keyer> for the consumer with Key+Fill.

It should solve your problem.

I think internal uses the internal keyer of the Duo2 and delete the line or set it to default for non keying outputs.
For Key+Fill you will have to set the right Settings in Blackmagics Desktop Video Utility. For Device 1 it should be SDI 1 & SDI 2, Device 3 SDI 3 and Device 4 SDI 4.

Privacy Policy   Terms of Service