Connecting to Caspar on Win 10

It drives me nuts. I try to connect from a Win 7 machine to a Caspar running on a Win 10 machine. No matter what I do in the “Defender Firewall” settings on Win 10 it does not work. I can connect the other way around, but that does not solve the problem. Any Win 10 geeks around, that have an idea?

Never had an issue with it - been running everything on Win10 for a few years. You’ve probably double checked the port in the config. Does it work locally? Do you see casparcg when you run netstat -a -b in cmd (or you can open Resource Monitor select the Network tab and then check Listening ports)?

Hi Hrein,

yes, I see it in netstat. I also tried to disable the firewall entirely and also opening port 5250: No way. So Win 10 seems to simply not allow this.

Like I said, never had an issue like this on Win10 - all my CCG’s are controlled remotely. Have you tried disabling defender firewall?

Did you disable the firewall from the WF.msc applet?
Try disabling all the profiles.

1 Like

Yes I tried this. What I cannot try is, what happens when I try to connect with a Win 10 machine, as I currently only have one. I only add new OSes to new machines and normally run the others until they break without modifying too much. But never mind, I wil find another solution. Thanks.

…will try that.

That seems to do it. I need to switch of the “public profile”. I was thinking that this is for everything coming in from the internet, while the domain and private profiles are for the stuff inside the LAN, but that seems not to be the case. Thanks.


Those profiles are automatically selected when you connect to a network for the first time.
A panel pops up asking if you want other computers and devices in the network to find the computer. If you click yes, the Private profile is applied to the network, if not, the Public profile is applied instead.
The Domain profile only is selected when the computer has joined an Active Directory domain.


Thanks for the explanation. This is good to know, as to me it would be more meaningful to name a profile public if it applies for the whole world (as in public domain). But the world seems very small in the eyes of a Win 10 system :smiley:

Oh yes! That is a very dumbed down naming scheme. It’s probably designed that way with portables in mind, where you connect to your “private” network in your house/work and to a “public” network in a coffee shop.

By the way, I recommend you to to shut down Windows Update completely. A server should never update itself on its own, as windows thinks it’s idle and restart it.

1 Like

You are right. I switched it to the most conservative setting that I found. It is my office system mostly used for development, so not actually a sever. The systems I use “outside” for production are all still running Win 7. I need Win 10 in the office only because I need the latest Adobe CC programs to be able to open clients data. As they stopped supporting Win 7 I needed one box with a win 10. In the mean time it runs quite stable, what was not always the case.

Today I experiment with ScoreboardOCR, that I have a license on one of the Win 7 machines, and wanted to update the Caspar on the Win 10 box. That is why all the trouble started… :smiley:

You can select Ethernet in the settings app and mark it as a metered connection. This should buy you some time.