Changes NDI codec settings.

We use casparcg with NDI output. When we start the ndi stream on the decoder, the picture is terrible. There is a suspicion that this is due to the SHQ7 codec in which casparcg is running. Is it possible to switch casparcg codec to SHQ2 in the settings?

Changing the used codec is only possible in the source code, I guess. But before that I would just try everything else.

I used NDI multiple times without any quality issue, so I would have an eye on the network performance. Do you have a Gigabit Ethernet? Do you have other stuff running on the same network? Can you do a test setup, in a physically separate network, where Caspar and the decoder (what decoder?) are the only two devices? Do you have the problem in that environment also?

From googling SHQ2 vs SHQ7 I see not much difference in specifications between the two…


| Do you have a Gigabit Ethernet?
Yes. we use the same line for connect magewell ndi encoder-> decoder. Everything works fine. But when we change the source to Caspar ndi out to magewell ndi decoder, picture is bad(

| Can you do a test setup, in a physically separate network.
Ok. I will try…

What version of Caspar are you using and what’s your config?


v2.3.3 on linux OS

I am sorry, I forgot to admit that at NDI monitor( pictures are with good quality.

I suppose that issue is with SHQ7.

|Do you have other stuff running on the same network?

I’ve made few additional tests, and it is obviously not an Ethernet issue. For example when I use ndi video SHQ2 in kiloview multiview, picture is ok ( but when I use ndi SHQ7 with casparcg - picture is low quality.

Therefore I would like to change NDI codec’s settings.

|Changing the used codec is only possible in the source code

I am not familiar with this SW, would you please help me which parameter has to be changed in it to make this setting change?

Example picture:

I’m guessing that it can’t work with NDI streams that have alpha.

I think so too.
I wanted to change the CG codec’s settings, but I don’t know-how :slight_smile:

If you don’t need alpha you could try modifying src/modules/newtek/consumer/newtek_ndi_consumer.cpp

So that:
will be:

And you might need to change all * 4 to * 3 in the same file (test without that change first).

Thanks a lot :slight_smile:

I’m going to try!

Aha, so you define “low quality”. Good to know. :slight_smile:

For me that is not low quality, but a color mode mismatch. I think the kiloview expect some YUV color mode, while Caspar is sending RGB or something like that. If NDI monitor shows the colors correctly, the problem is not with Caspar, but with how the Kiloview viewer displays it. So another RGB codec will not change much I guess.

|Aha, so you define “low quality”. Good to know. :slight_smile:

Sorry) English is not my native language.

|color mode
Good idea! Thanks! Can I change color mode for NDI in Caspar? like experiment…

It’s also not my native language :slight_smile: Sorry, just teasing you… Swiss-German is my native language, something that not even the Germans understand :slight_smile:

AFAIK you can not change the color mode in Caspar, you should talk to the Kiloview people, as it seems, that they mess it up somehow. It is always better to correct the problem, where it occures, than to work around it.

I am grateful for help!

|Germans understand
lol :laughing:

|talk to the Kiloview people
I’ve already written to kiloview.

Sorry for off topic.
Does anyone have an idea, how to make multicast from NDI, on Linux? Maybe it would help me)

You can also monitor the signal on PC with Newtek NDI monitor.
This is for free on (ndi tools)

multicast on linux should be able to be done by siennas access manager

Kiloview Multiview can’t even display NDI test patterns from NDI 5 Tools… Output from CasparCG and OBS NDI - same thing. so… waste of time.

Maybe you could try using ndi bridge as local transcode mode and try the various options? Maybe could help with the compatibillity. just an idea.