CasparCG server output stream

config
server

#1

hello i need how can stream to selected network card or network interface ,i have 2 network cards

thanks


#2

I usually prefer not to stream from Caspar. Since you get a NDI out of Caspar I think its easier to take Caspars NDI-output into OBS and stream with a tool made for streaming.


#3

Adding up to the previous answer, and from my own experience, this is a recommended setup:

Once you get everything ready, you need to:

  1. Set your caspar.config Server channel with an ndi-consumer. You can do it by adding this to your channel’s consumers:

    <channel>
      <!-- channel settings -->
      <consumers>
        <!-- other consumers you might need -->
        <ndi>
          <name>CasparCG NDI Output</name>
        </ndi>
      </consumers>
    </channel>
    
  2. In OBS set a Scene with an NDI Source. That source must be pointing to your CasparCG NDI Output. In my case, for example, my computer is called TRANSMISIONES and the NDI Source name is Transmision-Aire.

  3. In OBS preferences, check for Advanced > Network. There you can set which network interface you’ll use for streaming.


#4

no i need to stream to vlc in onther pc but i need to stream to select interface in my pc because i have one for internet and for data video
thanks


#5

I think your defined IP for network interface will automatically select it.


#6

You should have said so in you initial question, then. But nevertheless, I still think NDI can do a good job around your use case.

Would you mind to explain your situation better so we can help? Be detailed if possible, but explain your case as thorough as possible: what you have and how is it organized, what do you want or expect to happen regarding CasparCG or any software.


#7

best idea but just play video without audio do you have idea ?


#8

In obs no audio in from caspar client but in casparcg client have audio


#9

any idea because just out video without audio


#10

Try testing the source in NDI Studio Monitor.
Does the VU meter moves in the source? Keep in mind that OBS won’t play any sound through the software, only through the stream. You need to enable monitoring in the ‘Advanced Audio Properties’ panel (click the cogwheel next to the NDI Source in the audio mixer). In there you select ‘Monitor and Output’ in the ‘Audio Monitoring’ column.


#11

As @rrebuffo said, and complementing his answer, in OBS you can monitor the audio output from any of your sources using the Audio Mixer below, clicking the cogwheel and selecting Advanced Audio Properties.

In the following window, in your source, beside the latency settings you can change the monitor status.

  • Monitor off will output the audio normally to the streaming output. You will not hear anything, but the audio is actually going out.
  • Monitor Only (mute output) will mute the audio to the outside, but you will be able to listen the input.
  • Monitor and Output will send the audio both to you and to the outside at the same time.

#12

still no audio

in casparcg client have audio
image


#13

Which version of Server, Client and NDI Runtime have you installed?


#14

clinet : 2.0
server : 2.1
ndi : v4

but im add airsend prossesinng file manual


#15

The NDI plugin seems broken. It should include audio and the source name looks like a placeholder.
Have you tried in NDI Studio Monitor?


#16

yess same problem video without audio


#17

done working with casparcg server d442a8f8 dev
image


#18

Be careful with frontend with server 2.2+ it could break your config file.