CasparCG Server crashing/closing when I play a file

Hey,

Just trying to test CasparCG out for a playback option.

Unfortunately I’m having a bit of an issue getting it to actually play a video.

Getting the server and client setup, running and connected is fine. But as soon as I hit play on the client the server just closes with nothing in the log pointing to what has happened. I’ve included an example of the log below.

That hardware/OS I’m running isn’t exactly what is suggested, but isn’t lacking in grunt. Pretty sure that could be the problem tho, but would like to know if anyone else has overcome this issue.

-Windows 11
-AMD Ryzen 9 3900X
-AMD 5700XT

Any help would be appreciated.

Cheers


[2022-12-10 22:41:28.973] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2022-12-10 22:41:28.974] [info]    video_channel[1|1080i5000] Successfully Initialized.
[2022-12-10 22:41:28.975] [info]    Screen consumer [1|1080i5000] Initialized.
[2022-12-10 22:41:29.002] [info]    oal[1|1080i5000] Initialized.
[2022-12-10 22:41:29.002] [info]    Initialized channels.
[2022-12-10 22:41:29.008] [info]    Initialized controllers.
[2022-12-10 22:41:29.008] [info]    Initialized osc.
[2022-12-10 22:41:29.505] [info]    async_event_server[:5250] Accepted connection from 127.0.0.1 (1 connections).
[2022-12-10 22:41:29.505] [info]    Received message from 127.0.0.1: VERSION SERVER\r\n
[2022-12-10 22:41:29.505] [info]    Sent message to 127.0.0.1:201 VERSION OK\r\n2.3.2 4de6d18f Dev\r\n
[2022-12-10 22:41:29.505] [info]    Received message from 127.0.0.1: INFO\r\n
[2022-12-10 22:41:29.505] [info]    Sent message to 127.0.0.1:200 INFO OK\r\n1 1080i5000 PLAYING\r\n\r\n
[2022-12-10 22:41:29.505] [info]    Received message from 127.0.0.1: CLS\r\n
[2022-12-10 22:41:29.506] [info]    Received message from 127.0.0.1: TLS\r\n
[2022-12-10 22:41:29.506] [info]    Received message from 127.0.0.1: DATA LIST\r\n
[2022-12-10 22:41:29.506] [info]    Received message from 127.0.0.1: THUMBNAIL LIST\r\n
[2022-12-10 22:41:29.514] [info]    Sent message to 127.0.0.1:200 CLS OK\r\n"FORBIGGERBLAZES"  MOVIE  2498125 20221210213428 360 1001/24000\r\n\r\n
[2022-12-10 22:41:29.517] [info]    Sent message to 127.0.0.1:200 TLS OK\r\n\r\n
[2022-12-10 22:41:29.517] [info]    Sent message to 127.0.0.1:200 DATA LIST OK\r\n\r\n
[2022-12-10 22:41:29.525] [info]    Sent message to 127.0.0.1:200 THUMBNAIL LIST OK\r\n"FORBIGGERBLAZES" 20221210T213428 43662\r\n\r\n
[2022-12-10 22:42:30.906] [info]    Received message from 127.0.0.1: LOAD 1-10 "FORBIGGERBLAZES" CUT 1 Linear RIGHT   LOOP\r\n
[2022-12-10 22:42:30.908] [info]    Sent message to 127.0.0.1:202 LOAD OK\r\n

Can you play that file in VLC Player?

Hey Didi, yeh, VLC plays them fine.

Having the same issue with image and audio files too. Even when just loading them.

Hi,
Maybe log level debug would give you more info to work with.

The debug folder did have an error in:

“[1211/193747.097:ERROR:gpu_process_transport_factory.cc(990)] Lost UI shared context.”

I saw this has been a thing before on the forum here, but i appear to have different issues related to it.

I’ve tried changing the option to true but i am still getting the same crash result with no other information.

Might be related to this Bug with latest AMD PRO drivers 22Q4 · Issue #1450 · CasparCG/server · GitHub ?
Could you maybe try with older GPU drivers?

I’m having the same problem with the sver crashing when I send a play command from either client or excel. I notice that we both using AMD 5700XT. The bottom of my log file when running the stabel server is.


[2022-12-16 14:19:33.218] [info]    Received message from 127.0.0.1: CG 1-20 ADD 1 "LOWER-THIRD" 1 "<templateData><componentData id=\"f0\"><data id=\"text\" value=\"First Name\" /></componentData><componentData id=\"f1\"><data id=\"text\" value=\"Last Name\" /></componentData><componentData id=\"f2\"><data id=\"text\" value=\"\" /></componentData><componentData id=\"f3\"><data id=\"text\" value=\"\" /></componentData><componentData id=\"f4\"><data id=\"text\" value=\"\" /></componentData><componentData id=\"f5\"><data id=\"text\" value=\"\" /></componentData><componentData id=\"channel\"><data id=\"text\" value=\"1\" /></componentData><componentData id=\"layer\"><data id=\"text\" value=\"20\" /></componentData></templateData>"\r\n
[2022-12-16 14:19:33.262] [info]    D3D11: Selected adapter: AMD Radeon RX 5700 XT
[2022-12-16 14:19:33.262] [info]    D3D11: Selected feature level: 45312
[2022-12-16 14:19:33.263] [info]    Sent message to 127.0.0.1:202 CG OK\r\n

We had the same Problem with our AMD Machine since a couple of weeks. We could fix it by rolling the GPU Driver back to a Version from April 5th. Version: 30.0.15021.1001

Maybe it also works with a slightly newer Version, but this is how it worked for us.

I think the Problem started after a Windows Update, but not 100% sure.

GPU: AMD RX 580
CPU: AMD Ryzen 7 2700X
Windows: Windows 10 22H2

1 Like

Thank You. Rolling back the driver resolved this for me too

Thanx a lot! Worked for me.

Privacy Policy   Terms of Service