CasparCG Hyperdeck

Hi everyone!

I know this is not fully CasparCG, but it´s related to it…
Want wo build this Hyperdeck-CasparCG Connector:

Sadly I always get this error on second step:

casparcg-hyperdeck-master\libs\node-osc>npm install
npm WARN hyperdeck-proxy@1.0.0 No repository field.

Any ideas what´s wrong here?

It’s just a warning. Did you follow Peter’s instructions at the bottom of the readme?

Ok, thanks. For the clarification.

But now I´m stuck at point 3…

casparcg-hyperdeck-master\libs\casparcg-connection>npm run build:main
npm ERR! missing script: build:main
npm ERR!
npm ERR! Did you mean one of these?
npm ERR! build
npm ERR! build-win32

Try npm run build

That gives just a bunch of error messages…

casparcg-hyperdeck\libs\casparcg-connection>npm run build

hyperdeck-proxy@1.0.0 build C:\casparcg-hyperdeck

src/caspar-adapter.ts:3:33 - error TS2307: Cannot find module ‘…/libs/casparcg-connection/dist’ or its corresponding type declarations.

3 import {CasparCG, Command} from “…/libs/casparcg-connection/dist”;

src/caspar-adapter.ts:4:22 - error TS2307: Cannot find module ‘…/libs/node-osc/lib’ or its corresponding type declarations.

4 import {Server} from “…/libs/node-osc/lib”;

src/template-adapter.ts:6:33 - error TS2307: Cannot find module ‘…/libs/casparcg-connection/dist’ or its corresponding type declarations.

6 import {CasparCG, Command} from “…/libs/casparcg-connection/dist”;

src/template-adapter.ts:7:22 - error TS2307: Cannot find module ‘…/libs/node-osc/lib’ or its corresponding type declarations.

7 import {Server} from “…/libs/node-osc/lib”;

Found 4 errors.

npm ERR! errno 2
npm ERR! hyperdeck-proxy@1.0.0 build: tsc
npm ERR! Exit status 2
npm ERR!
npm ERR! Failed at the hyperdeck-proxy@1.0.0 build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Could anyone try to build it please?

I tried, and here is the build.

1 Like

Wow! That´s so kind of you :slight_smile:

Thank you very much for you help Vimlesh!

Works really great.

1 Like

I tried the build from vimlesh. I can see a emulated HyperDeck. and the clipserver is connected. However, I can’t play or see any clips from the CasparCG media folder. What am I doing wrong? I tried the OSC ports in the settings file and the Firewall has access. I run the casparCG server, the scanner.exe and the hyperdeck clipserver build.

I use CasparCG server 2.3.3 LTS


Hi TheYouth,

Can you describe how you got the build from Vimlesh working? The ATEM is connected to the emulated Hyperdeck, but cannot see the clips inside the CasparCG folder. I am running the CasparCG server, scanner, the Client and the clipserver.exe.

So there is a connection with the “Hyperdeck”, but no clips visible.

Thanks for your help!

hi @all,

i’ve compile, install and start the caspercg connector after i’ve change the local IP adress, from 10.x.x.x to 172.x.x.x, in clipserver.json or templateserver.json files. After them can i connect the Atem Control Software and emulate the caspercg hyperdeck software.
My question how can i list the clips to an order or with a .csv file. Can anyone help me!

thanks to all

is there anyone here who can guide me? I got the client and template server running but no media content is listed in ATEM Software Control! Although the video content folder includes mp4 and mov. I do not know anymore

Privacy Policy   Terms of Service