Casparcg.config - Idiot-advice


#1

Hey Folks,
im Using CasparCG now for over two Years and its workin fine so far, but im most time totally lost when it comes to the coding part of the casparcg.config file. I got through this all by searching the old forum, took it’s time but I got there^^ Now, by deleting the file im starting again from scratch and could use some help. Well my setting is simple:

i have two decklink 4K extreme with both fill&key output. That works fine.
My Problem:

  • There is no audio. Either SDI embedded nor via L+R-XLR (I just need stereo Left/Right)
  • I can’t see the rundown time in the casparcg Client window.
  • No audio Level in CasparCG Client.

Can anybody help me with that? that would be awesome. Thanks.
Here is my actual setting:

<configuration>
  <paths>
    <media-path>E:\\casparcg\\_media\\</media-path>
    <log-path>E:\\casparcg\\_log\\</log-path>
    <data-path>:\\casparcg\\_data\\</data-path>
    <template-path>E:\\casparcg\\_templates\\</template-path>
    <thumbnails-path>E:\\casparcg\\_thumbnails\\</thumbnails-path>
  </paths>
<auto-mode>true[true|false]</auto-mode>
  <channels>
 
    <channel>
        <video-mode>1080i5000</video-mode>
        <consumers>

<decklink>
                <device>1</device>
                <embedded-audio>false [true|false]</embedded-audio>
                <latency>normal [normal|low|default]</latency>
                <channel-layout>stereo </channel-layout>
                <custom-allocator>true [true|false]</custom-allocator>
                <buffer-depth>4 [1..]</buffer-depth>
            </decklink>
        
        </consumers>
    </channel>

<channel>
        <video-mode>1080i5000</video-mode>
        <consumers>

<decklink>
                <device>2</device>
                <embedded-audio>false [true|false]</embedded-audio>
                <latency>normal [normal|low|default]</latency>
                <channel-layout>stereo </channel-layout>
                <custom-allocator>true [true|false]</custom-allocator>
                <buffer-depth>4 [1..]</buffer-depth>
            </decklink>
         
        </consumers>
    </channel>


  </channels>
  <controllers>
    <tcp>
        <port>5250</port>
        <protocol>AMCP</protocol>
    </tcp>
  </controllers>
</configuration>

Maybe it is possible, to have a kind of “guide” for guys like me, to get more into the settings. The actual wiki is not really the place for easy diving into the materia.

Greetings from Hamburg Germany! :slight_smile:


#2

See


You only can choose one option in a line
embedded-audio>false [true|false]
Correct:
embedded-audio>true


#3

Hey peteraellig,
thank you for your fast response. That was easier than I thought. Audio works now! YAY :slight_smile:
but still not getting trough, why the rundown is not showing. The clip is playing but I can’t either see the timecode running nor audio level in the client.
Any suggestions?
32


#4

I´m also from Hamburg :slight_smile: Great to see a new user from here :slight_smile:


#5

I had several times the same issue, for now i think one of the the 2.1 versions here , you should find it in a topic here , which discusses the development and the newest 2.2 builds showing all audios and running on my system.
Sorry, but the forum software is not made for my little iphone screen, otherwise i would send you the link and config tomorrow, back at home.


#6

OK:
i run a 2.1 build from a topic here:
Updates server/client?
the build can be downloaded from
here

as client i run the latest build from the caspar ftp server.
you find a link on the caspar main page.
CasparCG Server development builds

(the link on the website http://builds.casparcg.com/CasparCG/20Server/2.1.0 ends dead, http://builds.casparcg.com/ is correct)
there you find new builds, also for server 2.2.

unfortunately the different servers and clients have not a similar behavior with running time and audio tracks, some of then show audio only, some of them none of both.

here my config for a one channel decklink card with 8 audios embedded:
if you have more channels, duplicate the whole section
<channel> inside <channels>
and set the
<device> number to 2… 3… 4…

> <?xml version="1.0" encoding="utf-8"?>
> <configuration>
>   <paths>
>     <media-path>D:\media</media-path>
>     <log-path>C:\CasparCG Server 2.1\server\log/</log-path>
>     <data-path>D:\data/</data-path>
>     <template-path>D:\template</template-path>
>     <thumbnail-path>D:\thumbnail/</thumbnail-path>
>     <font-path>C:\Windows\Fonts</font-path>
>   </paths>
> 
>   <lock-clear-phrase>secret</lock-clear-phrase>
> 
> 	<thumbnails>
>     	<generate-thumbnails>false</generate-thumbnails>
>   </thumbnails>
> 
> <mixer>
>     <straight-alpha>true</straight-alpha>
> </mixer>
> 
>   <channels>
>
>     <channel>
>        <video-mode>1080i5000</video-mode>
>        <channel-layout>8ch</channel-layout>
>         <consumers>
>           <decklink>
>             <device>1</device>
>             <embedded-audio>true</embedded-audio>
>             <channel-layout>8ch</channel-layout>
>             <latency>low</latency>
>             <buffer-depth>3</buffer-depth>
>             <custom-allocator>true</custom-allocator>
>           </decklink>
>         </consumers>
>     </channel>
>
>
>   </channels>
> 
>  
>   <controllers>
>     <tcp>
>       <port>5250</port>
>       <protocol>AMCP</protocol>
>     </tcp>
>     <tcp>
>       <port>3250</port>
>       <protocol>LOG</protocol>
>     </tcp>
>   </controllers>
> </configuration>