CasparCG Client the last version of it

Hi folks,

Ive downloaded the last release of the CasparCG Server 2.4.0 NRK RC2 and scanner for media detection. The problem that I have so far is with CasparCG Client which cant detect any media or template inside video/. template/, etc… So as far as I understand the Client is not connected working correctly with the server. So there is any Client Version out there that works fine with this server version? If yes, please can you help me with it?




I am also facing the same issue from today…

Check the server window when you start the client, if connected correctly you should see something like client [ip address] connected

if not: check client preference → server configuration

if yes: then could be that the scanner is not running or the media folder is not correctly specified in the server configuration file

I don’t know what else could be without more information

anyway, check always server window for clue when you have issues

Fixed… Please, follow this instruction and I`ve also renamed my media files. Something was wrong with their names.



Thank you for the reply. But unfortunately, still Caspercg client can’t detect templates. The connection between Caspercg server and client is successful. I have also checked the scanner, it is running properly. Issue is not solved yet.

You can identify if the lack of templates listed is a client issue or a server/scanner issue by entering some commands directly in the CasparCG Server window.

The command cls (upper or lower case) tells the server to display a list of media files including some properties such as the type (MOVIE, AUDIO, STILL), file size etc. The equivalent command for templates is tls. These are the commands the client sends to the server when the client starts.

If the tls command lists templates there is a problem between the client and the server, but this is very improbable.

If no templates are listed check the paths section in your casparcg.config file. It is important that the path includes a final separator, and of course that the folder exists with some template files (yes - I made that mistake on 1 install!!). For example on a windows hosted server:


Note the double backslash characters are needed because the backslash is an escape character in xml. I tend to enter all my paths using the forward Unix style slash, which Windows uses without problem.


There is a newer version (year 2020 build) of the version 2.2 client available from the builds server at Navigate to folder /builds/CasparCG Client/next and download file The file date is 13th July 2020. When first run, the newer client version will update your stored configuration to the latest database version (216). The older client may not work 100% correctly after the newer client has been run because of the changes in the database tables.

1 Like

Hii Andyw,
Thank you for the detailed explanation. My issue is solved.


What server version are you using?



CasparCG Server 2.3.3

Privacy Policy   Terms of Service