CASPAR server SDI and NDI output best and easiest workflow

Hello. I am running the latest Caspar server with the Caspar client with Decklink cards for SDI out and all works perfect.
I wanted to have the outputs at the same time as NDI and I followed the instrucions from here

It works fine by only doing the following:
Added the
<ndi> <name>[custom name]</name> <allow-fields>false [true|false]</allow-fields> </ndi>
in the config file.

After that I send the command
“add 1 ndi name xyz”
in the server window

and I got the xyz NDI channel available in my network.

QUESTION: Is it a way to set up the server so it will always produce the NDI output without the need to write the command in the server window each time?
I need to make sure the system will start that way so my colleagues using the server don’t need to write the command.
Many thanks for any help.


You should get rid of everything between square brackets [] so that it becomes valid XML. You can add a text instead of the custom name, but WITHOUT the brackets. That is what is displayed, when you list NDI sources.

You added this XML in the consumer part of a channel, did you?

I added the code
<ndi> <name>caspar1_studio7</name> <allow-fields>false [true|false]</allow-fields> </ndi>
before the tag and it works now. Many thanks for the advice.

As I said earlier: Everything between [ and ] is wrong. It is there to tell you, what the possible settings are. But it is INVALID in an XML document. So the line <allow-fields>false [true|false]</allow-fields> will currently be ignored.

For your reference: The full channel should look something like this, where a few of the settings for the Decklink can be omitted:


Hi again! Ok got it, changed now and looks good. Many thanks for the help.

Privacy Policy   Terms of Service