Caspar crashes after installing a Radeon RX 560

Hello! Not sure if this is the right place to ask, but I’ve been having issues after installing a Radeon RX 560.

This computer was previously using the integrated Intel graphics to run Caspar, and it worked with no problems. Caspar outputted to a Decklink Duo card. No other changes have been made to the computer.

The following has been happening after installing the card:

1 - The server opens

  • All the versions (from 2.3.0 to the most recent beta) launch successfully.
  • All load the settings, and if outputting to a window, the window opens.

2 - When prompted to play any video or template the server crashes (happening on all versions)

  • Used the original Caspar client and SuperConductor

Other software is able to use the GPU and decode or play video without a problem. This includes OBS. I know is an older GPU, but it would be nice to use it still.

See the log below in case it helps. Thanks in advance!


Starting CasparCG Video and Graphics Playout Server 2.3.2 4de6d18f Dev
[2023-12-17 13:56:56.916] [info] Initializing OpenGL Device.
[2023-12-17 13:56:56.924] [info] Initialized OpenGL 4.5.0 Core Profile Context ATI Technologies Inc.
[2023-12-17 13:56:56.925] [info] Initialized image module.
[2023-12-17 13:56:56.925] [info] Initialized ffmpeg module.
[2023-12-17 13:56:56.926] [info] Initialized oal module.
[2023-12-17 13:56:56.926] [info] Initialized decklink module.
[2023-12-17 13:56:56.926] [info] Initialized screen module.
[2023-12-17 13:56:56.926] [info] Initialized newtek module.
[2023-12-17 13:56:57.019] [info] Initialized html module.
[2023-12-17 13:56:57.019] [info] Flash support is disabled
[2023-12-17 13:56:57.019] [info] Initialized flash module.
[2023-12-17 13:56:57.019] [info] Initialized bluefish module.
[2023-12-17 13:56:57.019] [info] “C:/casparcg-server-v2.3.3-lts-stable\casparcg.config”:

** Config File unmodified from download (because of the XML it doesn’t dislplay)

[2023-12-17 13:56:57.138] [info] Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2023-12-17 13:56:57.138] [info] video_channel[1|720p5000] Successfully Initialized.
[2023-12-17 13:56:57.140] [info] Screen consumer [1|720p5000] Initialized.
[2023-12-17 13:56:57.217] [info] oal[1|720p5000] Initialized.
[2023-12-17 13:56:57.217] [info] Initialized channels.
[2023-12-17 13:56:57.218] [info] Initialized controllers.
[2023-12-17 13:56:57.218] [info] Initialized osc.
[2023-12-17 13:57:48.100] [info] async_event_server[:5250] Accepted connection from (1 connections).
[2023-12-17 13:57:48.124] [info] Received message from VERSION SERVER\r\n
[2023-12-17 13:57:48.124] [debug] Executing command: VERSION
[2023-12-17 13:57:48.124] [debug] Executed command (0s): VERSION
[2023-12-17 13:57:48.124] [info] Sent message to VERSION OK\r\n2.3.2 4de6d18f Dev\r\n
[2023-12-17 13:57:48.124] [info] Received message from INFO\r\n
[2023-12-17 13:57:48.124] [debug] Executing command: INFO
[2023-12-17 13:57:48.124] [debug] Executed command (0s): INFO
[2023-12-17 13:57:48.124] [info] Sent message to INFO OK\r\n1 720p5000 PLAYING\r\n\r\n
[2023-12-17 13:57:48.124] [info] Received message from CLS\r\n
[2023-12-17 13:57:48.124] [debug] Executing command: CLS
[2023-12-17 13:57:48.125] [info] Received message from TLS\r\n
[2023-12-17 13:57:48.125] [info] Received message from DATA LIST\r\n
[2023-12-17 13:57:48.125] [info] Received message from THUMBNAIL LIST\r\n
[2023-12-17 13:57:48.134] [debug] Executed command (0.009s): CLS
[2023-12-17 13:57:48.134] [info] Sent message to CLS OK\r\n"COUNT_DOWN" MOVIE 3701167628 20231217133605 54504 1001/30000\r\n\r\n
[2023-12-17 13:57:48.134] [debug] Executing command: TLS
[2023-12-17 13:57:48.136] [debug] Executed command (0.003s): TLS
[2023-12-17 13:57:48.136] [info] Sent message to TLS OK\r\n\r\n
[2023-12-17 13:57:48.136] [debug] Executing command: DATA LIST
[2023-12-17 13:57:48.136] [debug] Executed command (0s): DATA LIST
[2023-12-17 13:57:48.137] [info] Sent message to DATA LIST OK\r\n\r\n
[2023-12-17 13:57:48.137] [debug] Executing command: THUMBNAIL LIST
[2023-12-17 13:57:48.143] [debug] Executed command (0.007s): THUMBNAIL LIST
[2023-12-17 13:57:48.143] [info] Sent message to THUMBNAIL LIST OK\r\n"COUNT_DOWN" 20231217T133605 79432\r\n\r\n
[2023-12-17 13:58:00.095] [info] Received message from PLAY 1-10 “COUNT_DOWN” CUT 0 Linear RIGHT\r\n
[2023-12-17 13:58:00.096] [debug] Executing command: PLAY
[2023-12-17 13:58:00.097] [debug] ffmpeg[COUNT_DOWN.mp4|0.0000/0.0000] seekable: 2
[2023-12-17 13:58:00.098] [debug] Executed command (0.003s): PLAY
[2023-12-17 13:58:00.098] [info] Sent message to PLAY OK\r\n

… Then the program crashes

Processor Intel(R) Core™ i7-9700K CPU @ 3.60GHz 3.60 GHz
Installed RAM 16.0 GB
GPU Radeon RX 560 Series - Primary/Discrete
VRAM 4096 MB - GDDR5 1750 MHz
Driver Version
AMD Windows Driver Version 31.0.21905.1001
Direct3D API Version 12.0
OpenGL® API Version 4.6
Direct3D® Driver Version
OpenCL® Driver Version 31.0.21905.1001
OpenGL® Driver Version 23.10.230729_569461f
2D Driver Version
Windows Edition Windows 11 Professional (64 bit)
Windows Version 22H2

That is weird. Usually, when something happens inside Caspar the error gets logged. So it looks to me like something happening in the GPU driver or elsewhere. Did you noticed, that AMD GPU’s are not officially supported? Only nVidia.

By the way: If you format your log-file snipped with the </> button, also the XML is shown.

Yeah, is definitively an uncaught crash, it doesn’t hang or show any dialogue, it simply closes. But no, I didn’t noticed that AMDs weren’t supported, actually never came across minimum specs anywhere, still what a shame. With more time I’ll download the sources and see if building from those gives me more insights.

Anyways, thanks for the response!

This could be the same issue as Bug with latest AMD PRO drivers 22Q4 · Issue #1450 · CasparCG/server · GitHub

In my case I had to go with an even older version, 2019 driver seem to be working fine, lol. Definitively more testing needs to be done to see if its stable, but problem solved! Thanks for the reply!