Caspar 2.2 stable and latest master: Video and Audio stuttering after about 75 min

server

#1

Hi to all,

I have a problem with Caspar 2.2 stable and latest master on Windows 7 64 bit with HP Z420, NVidia Quadro K2000 and Decklink Duo 2.

Setting:
Decklink Duo 2 Port 1 -> 1080p2997 IN
Decklink Duo 2 Port 2 -> 1080p2997 IN
Decklink Duo 2 Port 3 -> 1080p2997 IN
Decklink Duo 2 Port4 -> 1080p2997 OUT

I use several HTML layers for graphics and duplicated layers of my 1080p2997 IN signals (Video, Graphics, Video with Mixer Chroma for 3D graphics in the pool to show only for certain blue/green color)

in Addition I record:
ADD 1-1 FILE “FILENAME” -hwaccel cuvid -pix_fmt p0101e -c:v hevc_nvenc -preset slow -rc vbr_hq -format mpegts

After about 75 min. my output video is starting stuttering (you see it in video and hear it in the audio).
Example: https://youtu.be/Z_2A2RkynkE - last seconds

Does anybody else see that issue?

Here in the middle of the diag window you see starting the issue, nefore the diag output was quite good as far as I can say.

I have 16 GB ram, What I also saw was that Caspar is eating my RAM. When stuttering begins, RAM usage is more than 6.5 GB and free is nearly 0

Here a picture after restart of caspar
caspar3


#2

Your RAM is fine: The important value is “verfügbar” not “frei” and there is plenty of it.

It’s hard to tell what the problem is from the diags, but for me it looks like the decklink producer runs into trouble getting its buffer flushed.

Maybe a heat problem?


#3

Do you think heat?
How can I check heat live? I have CPUID HW Monitor but this only shows CPU, NVidia, RAM

But I immediately restart caspar and then it works immediately


#4

Here some images when stuttering is visible

CPU, RAM, NVidia

Memory
2


#5

I now checked my logs… every 74 min the systems starts stuttering… I am not sure if this is really heat… why exactly after 74 min? (i checked the last 2 days where I use the system 10+ hours a day)


#6

Is this 29.97 framerate mandatory? Could you try if it does the same with 25 or 50fps.


#7

Well, if it’s always every 74mins, thats curios and obviusly not a heat problem. That was just a wild guess.

Are you playing the same files and templates in the same order when this happens?

Other things that came to my mind:

  • a media file or template error?
  • a memory leak that breaks the memory address limit after a certain time or more likely a certain number of frames?

I would try to play something totally different than usual and see if you can get the same error.
Also, changing the Decklink driver versions tend to be a good try.


#8

@Didi
I will give a try next week with 25fps. TOday I have to finish with 29.97

@mcdikki
Do you mean with play sth total different just remove all html templates, Mixer settings etc. and play e.g. a video file ?
And then switch back?
I can also try this next week


#9

I’m able to replicate something similar. When I run at 29.97 or 59.94 I get strange pops in the audio playback and video will sometimes stutter a touch. If I change it to 30 or 60 fps these issues appear to go away. This is in 2.2 only, the 2.1 beta I had was fine in 29.97fps mode.