Can Reference be disabled in config?

With CasparCG Server 2.3.0 and a BlackMagice Decklink Duo video card can reference be disabled in the config for one channel?

My situation is this.
Channel/device 1 is providing a key and fill to a 1080i broadcast switcher which requires reference.
Channel/device 2 is doing an internal key over a separate 1080p signal. On this channel if reference from the switcher is connected to the BlackMagic card, the signal coming out of that channel glitches every few seconds

Is there a way to connect Reference to the Decklink card and configure the second channel to ignore it?

I don’t see an option for this in the Decklink API so I suspect the card either locks everything or nothing but I am hoping someone in here with more experience than me can tell me otherwise.

BTW, I can get around the glitches by frame syncing the source before the card but I’d prefer to save the equipment and delay if possible.

Thanks.


<configuration>
    <paths>
        <media-path>C:\\CasparCG\\casparcg-server\\media\\</media-path>
        <log-path>log/</log-path>
        <data-path>data/</data-path>
        <template-path>C:\\CasparCG\\casparcg-server\\template\\</template-path>
    </paths>
    <lock-clear-phrase>secret</lock-clear-phrase>
    <channels>
        <channel>
            <video-mode>1080i5994</video-mode>
            <consumers>
                <decklink>
                    <device>1</device>
                    <embedded-audio>false</embedded-audio>
                    <latency>low</latency>
                    <buffer-depth>3</buffer-depth>
                </decklink>
            </consumers>
        </channel>
        <channel>
            <video-mode>1080p5994</video-mode>
            <consumers>
                <decklink>
                    <device>2</device>
                    <embedded-audio>false</embedded-audio>
                    <latency>low</latency>
                    <keyer>internal</keyer>
                    <buffer-depth>3</buffer-depth>
                    <key-only>false</key-only>
                </decklink>
            </consumers>
        </channel>
    </channels>
    <controllers>
        <tcp>
            <port>5250</port>
            <protocol>AMCP</protocol>
        </tcp>
    </controllers>
    <amcp>
        <media-server>
            <host>localhost</host>
            <port>8000</port>
        </media-server>
    </amcp>
</configuration>
type or paste code here

You are syncing the card and I don’t know of a way in the Decklink API to disable it for certain connections. Another option for you would be to add another card.

Have you tryed different flavours off reff. like blackburst vs tri-level ?

I don’t think that this would make a difference as a reference signal is a reference signal and valid for all channels of the card. I think that the reference signal is only used in a “analog” way, that means, that the reference is used to clock the channels directly in hardware, without going to the software. That would explain, why you can not disable it. As Hreinn said: The only option is to add another card without a connected reference signal. But check the available PCIe lanes before doing so.

Thanks for the quick responses. That all makes sense and is as expected. It’s nice to have the confirmation of those with more experience.

Privacy Policy   Terms of Service