Buffer warning and laggy animation

Hi all,

I noticed always when the animation lagg/shutter (for example lower thirds with an after effects animation or even the built-in Caspar transitions) the logs of Caspar show me different warnings

[2020-07-02 15:53:06.171] [2748]  [warning] [buffer] Performance warning. Buffer mapping blocked: 0.041
[2020-07-02 15:53:06.172] [3340]  [warning] [ogl-device] Performance warning. Buffer allocation blocked: 0.029
[2020-07-02 15:53:06.172] [7892]  [warning] [channel] Performance warning. Produce blocked: 0.041
[2020-07-02 15:53:06.172] [7892]  [warning] [channel] Performance warning. Tick blocked: 0.041
[2020-07-02 15:53:06.206] [8788]  [warning] [channel] Performance warning. Consume blocked: 0.032
[2020-07-02 15:53:06.206] [7892]  [warning] [channel] Performance warning. Tick blocked: 0.034

Someone know what I can do about that?
My specs:
AMD Ryzen 7 1700X 8Core
Radeon RX Vega (card around 30 - 40% usage)
16 Gbyte memory

Try setting flash producer’s buffer to 5~10 frames

Two stupid questions from my side:

First: I’m not using flash templates, only HTML templates or videos/images. Do I have to set it neverless?
Second: I’m setting it in the Caspar configuration right?

edit: Now it lagged again, but no warning in the console. Instead something in diag showed up

Not stupid at all. Flash templates showed that mapping blocked errors when the buffer is set to auto.

Is v-sync enabled in the screen consumer? Decklink seems alright.

Looking at the graphs in the diag window, seems like you are using an HDD or a very slow SSD to load the files, those underflow events happen when the file is read slower than the playback needs

If it helps, set Windows energy consumption to High Performance. And if you’re using the latest official release, enable GPU for html in your config file.

<decklink>
			<device>2</device>
					<key-device>1</key-device>
					<embedded-audio>false</embedded-audio>
					<channel-layout>stereo</channel-layout>
					<latency>normal</latency>
					<keyer>external</keyer>
					<key-only>false</key-only>
					<buffer-depth>5</buffer-depth>
					<custom-allocator>true</custom-allocator>
		</decklink>

That’s my config for the card. I copied it from another thread.
Screen consumer has no other parameter.
The SSD that’s built in is HFS250G32TND-N1A0A, but I don’t know if thats a slow one or not.
The energy mode was on balanced I set it on high performance for now.

The biggest problem is, that these laggy animations are very random.

I also noticed at the start I get the following warnings:

[2020-07-03 10:30:17.128] [10364] [warning] Device does not support video-format: 1080p50
[2020-07-03 10:30:17.129] [10364] [info]    DeckLink Duo 2 [1-2|1080p5000] Disabled low-latency mode.
[2020-07-03 10:30:17.129] [10364] [info]    DeckLink Duo 2 [1-2|1080p5000] Enabled external keyer.
[2020-07-03 10:30:17.172] [9672]  [warning] [channel] Performance warning. Mix blocked: 0.07
[2020-07-03 10:30:17.172] [9672]  [warning] [channel] Performance warning. Tick blocked: 0.071

But it should support the video format?

A quick update from my side:
I got a temporary Samsung 860 EVO as my media/caspar drive.
So OS is running on the low SSD card and the Caspar server with his media files on the Samsung.

I still get performance and buffer warning when I tested it for an hour. Plus I got one lag in that time. I guess if it runs good it shouldn’t show a performance warning even once?

Privacy Policy   Terms of Service