Audio issues on 1080p50 or higher on Blackmagic UltraStudio Mini HD

I’m trying to use Blackmagic UltraStudio Mini HD (thunderbolt 3) on Windows 10 with 1080p50 output (fill+key).
Everything works perfectly on all 720p resolutions and 1080p25, 29.97 and 30.
On 1080p50, 59.94 and 60, I observe audio lags and cracks.
Same audio bugs using embedded audio on SDI, computer jack output or external audio USB card.
I read “Device may not support video-format: 1080p50” in log.

Windows 10 21H1, Desktop Video v.12.1. My computer is a NUC8i7. CPU is not capping and I see no dropped frames on debug.
I observe the same behavior on caspar-server 2.2.0 and 2.3.2 LTS.

I am not sure, if the UltraStudio Mini HD can do fill & key at 1080p50, as all of these thunderbolt interfaces are using only 4 PCIe lanes on the PC side, and that is probably not enough to get the data to the box. Does it work with 1080i50?

I use it often at 1080i50 with no problems at all. I never tried 1080p50 but it needs more bandwidth, I assume.

I can see the same issue reported by adlmr on my mini-dev/testbed system that comprises a NUC8i7BEH connected to two Thunderbolt 2 input daisy-chained UltraStudio 4k units via an Apple Thunderbolt 3 (NUC output) to Thunderbolt 2 converter (devices).

When I set both channels to 1080i50 operation I can play videos on both output interfaces without problems. When I set either channel to 1080p50 I see the same error log report as adlmr - “device may not support the video-format”. The video is good, but the audio breaks up on the 1080p50 channel. The other channel operating at 1080i50 retains good audio and picture outputs. 720p50 works correctly.

Total data rate for 2 channels at 1080i50 is that required for 1 channel at 1080p50, so data rate via the cable supports the required connection bandwidth, and the system used by adlmr has twice the interconnection bandwidth - Intel data sheet insists that the NUC has full 40 MBits/s available on Thunderbolt 3 certified cables.

I can play HTML templates on the 1080p50 channels, seeing the video and key signals from both UltraStudio outputs, with correct colours on the fill.

I rendered a short music video clip in DaVinci Resolve to be 1080p50. This clip is confirmed as 1080p50 by VLC. When I stop CasparCG server and use Blackmagic Media Express to reply the clip it sets the interface to 1080p50 and plays the clip with good audio on both interfaces. The 1080p50 mode is thus valid for the YCbCr connection used by Media Express.

So this does look like a CasparCG server issue with the information returned by the UltraStudio units as many other users report Decklink cards operating correctly at 1080p50.

I also tried 2160p25 operations on the interfaces. This mode also reported that the device may not support the video format. There is both a CasparCG video format and audio error. Fill and key operation is not functioning - lots of wrong colours and the fill is on both fill and key outputs. I think this means CasparCG has asked the device to switch to 2160p25 in Alpha Red Green Blue mode (ARGB) but the device refused.

Privacy Policy   Terms of Service