Alpha Problems with a TGA Sequence

config
graphics

#1

Hello,

So i have a 32-bit straight TGA sequence that supposedly is meant to be played at 1080i/25.

I tried multiple versions of caspar but i’m mostly working on 2.1.0.3440.

Now my issue is when i test the sequence animated or not i can’t seem to make it work properly unless it’s on a white background, corners are not drawn properly for example and transparency seems off even the first picture on the sequence that’s meant to be blank (only has alpha) shows graphics on the screen that are not meant to be there.

I have experimented with straight alpha and it seems to at least draw it properly almost but then there’s white imperfections on the graphics.

Any ideas about what i could do about this?

On the left black background on the right white background (which looks right) and on the bottom with straight alpha on


#2

How do you play that sequence? Is there a way to directly play a TGA sequence in CasparCG? I am not aware of any.

I usually import it into After Effects, set the clip (sequence) to straight alpha and render it as a QuickTime with Alpha (Animation codec) with premultiplied enabled. These files plays fine.

I think it does not do much to set the channel to straight alpha, as the compositing in the mixer stage is always premultiplied and only the output is then made to be straight. That is, because there are vision mixers, that do not support premultiplied keys.


#3

I do play the sequence “directly” but it is with a small piece software made by me but it’s essentially as if i just did PLAY 1-1 of each TGA file in the sequence on order, it’s was just a means to test the output and see what happens.


#4

I see. But that will not play at a full frame rate I guess :slight_smile:


#5

I will then have to add variable info on top of this, could this be achieved with a template using HTML and JavaScript?


#6

No, it will not work to play them directly, because they are not premultiplied and because it draws too much load on the CPU and file I/O to play TGA’s directly. These files are huge.


#7

I remember seeing the the same artefacts with QT Animation+alpha files. Switching from GPU to CPU accelerator fixed it on that occasion.


#8

Thanks for all of your help, i managed to make it work now how would i go about to add dynamic data on top?