2.0.7 crash Windows 10/11

Hi! We have some ‘legacy’ systems that still use Casparcg 2.0.7, and the other day it was unable to start on a machine with Windows 11. We blamed it on a corrupt Windows or similar and moved on.

Today tha same happened with a Windows 10 that was fine some days ago. Probably a Windows Update thing.

Event viewer complains about ntdll.dll

2.3.x versions open no problem. We’re working on updating everything.

Any ideas how to fix it for now?

Have you tried to roll back the last update? I usually block auto-updates from such legacy system completely using StopUpdates10.

1 Like

We didn’t have time to try a rollback, so I cannot confirm if that works.

Yeah I install Stop Updates everywhere I can as well but some systems are not under direct supervision.

Also tried to find fixes online for the specific dll but I couldn’t find anything promising.

Today I had more time to investigate this issue, it happened again.

The fix was to reinstall de GPU driver. In this case it was the latest one, but the date of the driver was probably not important, just a bad / corrupt installation.

Privacy Policy   Terms of Service