Win10 Telnet problem

Hi,

I’ve been using Caspar Server 2.0.7 on desktop computers with Win 7 (Decklink 4k and 8k cards) for a few years and everything has been working perfectly, but as I needed a more mobile option, I acquired a laptop with external video card (UltraStudio HD Mini) and Win10, so I moved to Caspar Server 2.2.0. Now Caspar Server can’t play some of my Flash templates - in particular, the ones with telnet. This is the AS3 code that I applied in the class:

var CasparTelnet1:Socket = new Socket(“localhost”, 6000);
CasparTelnet1.writeUTFBytes(“MIXER 1-12 FILL 0 0 1 1 \r\n”);
CasparTelnet1.writeUTFBytes(“MIXER 1-13 FILL 0 0 1 1 \r\n”);

I need to telnet from inside the template to server so that I can play video files and control templates in other layes.

That works for me. Check your Win 10 firewall settings and disable the “Private” section, so that the firewall only processes stuff coming from outside the LAN.

Did that - doesn’t work.

Maybe this information would help - I have to stick to ActiveX 14 on Win 7 for the templates with telnet to work. If I upgrade ActiveX to 32, those templates won’t play - same as on Win 10. Unfortunately, I can’t install ActiveX 14 on Win 10.

Hmm, have you tried to run it in 2.0.7? Maybe it’s something with the Caspar version. AFAIK you should not need to install any ActiveX in Win 10. What you also could try is set Win 10 to “developer mode” (Google for howto).

I’ve tried to run it in 2.0.7 on Win 10, but it didn’t work. When I remove the Socket variable definition from the class, the template works. I’ll try the developer mode.

I use this CustomSocket.as to connect back to Caspar. It also works in Win 10.

I’ve been trying to implement it, but unfortunatelly it seems that I don’t know how. I’m sorry to waste your time on basic stuff, but what do I need to do to apply it in my AS3 class? I’ve coppied CustomSocket in the same folder as my fla. file and imported it:

package 
{
	import flash.display.MovieClip;
	import flash.text.TextField;
	import flash.text.TextFormat;
	import flash.text.TextFieldAutoSize;
	import se.svt.caspar.ICommunicationManager;
	import se.svt.caspar.IRegisteredDataSharer;
	import se.svt.caspar.template.CasparTemplate;
	import flash.net.Socket;
	import CustomSocket;

        public class najava extends CasparTemplate

then used it this way

override public function Play():void
		{
		  	writeln("MIXER 1-15 FILL 0.2022 0.3228 0.2083 0.3704 \r\n");
		}

and got this message:

Error G:\Caspar Projekti\Test\najava.as, Line 102 1180: Call to a possibly undefined method writeln.

Sorry you need to add an object to your class:

public class najava extends CasparTemplate
{
   //class level variables
   private var mysocket:CustomSocket = new CustomSocket("localhost", 5250);

   //other code

   override public function Play():void
   {
      mysocket.writeln("MIXER 1-15 FILL 0.2022 0.3228 0.2083 0.3704 \r\n");
      mysocket.flush();
   }

   //other code
}

The flush command actually sends it to Caspar, so that always needs to be called at least once after a few lines of commands.

I think the \r\n at the end of the line could be left away, but it’s sure not wrong to add it.

Thank you. I did it this way, it works with ActiveX 14 on Win7, but not on Win10. It also doesn’t work with ActiveX 32 on Win7.

As I already said: You should not need to install the ActiveX. Try removing it, there is an utility from Adobe for that somewhere in the internet.

I’m working with Win 10 Pro and I don’t have ActiveX installed on it. I’ve read somewhere that ActiveX comes built-in with Win 10 and that it is impossible to uninstall it.

What Win 10 version would you recommend and do you think that might be causing this problem?

Could I ask you to try playing my template on your computer?

Privacy Policy   Terms of Service